1.清理系统上的旧版本php

# 可以使用以下方法

rpm -qa|grep php*yum list installed | grep php

# 一般需要清理的有以下软件

yum remove php php-devel php-cli php-common php-gd php-ldap php-mbstring php-mcrypt php-mysql php-pdo php55w-fpm

# 注意:使用的是yum卸载软件,在卸载前请检查确认不会删掉在用的软件,防止出错

2.更新系统上的php相关yum源

# 适用于CentOS5.x

rpm -Uvh

# 适用于CentOS6.x

rpm -Uvh

# 适用于CentOS7.x

rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpmrpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

3.安装需要的php版本

# 安装php5.5相关软件

yum install php55w php55w-devel php55w-cli php55w-common php55w-gd php55w-ldap php55w-mbstring php55w-mcrypt php55w-pdo php55w-mysql php55w-fpm

# 安装php5.6相关软件

yum install php56w php56w-devel php56w-cli php56w-common php56w-gd php56w-ldap php56w-mbstring php56w-mcrypt php56w-pdo php56w-mysql php56w-fpm

# 安装php7.0相关软件

yum install php70w php70w-devel php70w-cli php70w-common php70w-gd php70w-ldap php70w-mbstring php70w-mcrypt php70w-pdo php70w-mysql php70w-fpm

# 安装完成后可以使用以下命令检查