我们如图建立下列环境(环境由华为ensp模拟建立)

VLAN与Trunk配置


我们要实现的目的是
VLAN 5的2台主机能够互通,VLAN 10的2台主机能够互通。

VLAN 5与VLAN 10的2台主机不能够互通
在这其中交换机1的配置如下

[SW1]vlan 5 建立两个vlan分别为5和10
[SW1]vlan 10

[SW1]interface Ethernet0/0/1 进入e0/0/1口进行配置

[SW1-Ethernet0/0/1]port link-type access 将此端口配置为access模式

[SW1-Ethernet0/0/1]port default vlan 5 将此端口加入vlan5

[SW1]interface Ethernet0/0/2 进入e0/0/2端口进行配置

[SW1-Ethernet0/0/2]port link-type access 将此端口配置为access模式

[SW1-Ethernet0/0/2]port default vlan 10 将此端口加入vlan10

[SW1]interface Ethernet0/0/21 进入与第二台交换机相连的e0/0/21口

[SW1-Ethernet0/0/21]port link-type trunk 将其设置为 trunk模式

[SW1-Ethernet0/0/21]port trunk allow-pass vlan 5 10 并容许vlan5 和10 通过

交换机2的配置如下

[SW2]vlan 5 建立两个vlan分别为5和10
[SW2]vlan 10

[SW2]interface Ethernet0/0/3 进入e0/0/3口进行配置

[SW2-Ethernet0/0/3]port link-type access 将此端口配置为access模式

[SW2-Ethernet0/0/3]port default vlan 5 将此端口加入vlan5

[SW2]interface Ethernet0/0/4 进入e0/0/4端口进行配置

[SW2-Ethernet0/0/4]port link-type access 将此端口配置为access模式

[SW2-Ethernet0/0/4]port default vlan 10 将此端口加入vlan10

[SW2]interface Ethernet0/0/21 进入与第一台交换机相连的e0/0/21口

[SW2-Ethernet0/0/21]port link-type trunk 将其设置为 trunk模式

[SW2-Ethernet0/0/21]port trunk allow-pass vlan 5 10 并容许vlan5 和 10 通过

这样便实现了我们的目的

VLAN 5的2台主机能够互通,VLAN 10的2台主机能够互通

VLAN 5与VLAN 10的2台主机不能够互通